Exported Forms Missing Some Fields

I have configured two instances of the Medic application, one of a test server and another on a production server, both using the same XLSForms

While exporting data from the test server, I get all the fields, including one for testing.cov_test, with results, while the production server doesn’t display the fields, which is required by our project team as shown below
Please advise on the possible cause and solution

Hi @oyierphil

Could you please describe how you are exporting data?
Is it by using this endpoint API to interact with CHT Applications | Community Health Toolkit or another method?


I am using https://URL/admin/#/export/reports, thus I login as admin and use the export option at the bottom of the page

@diana, from the submitted forms, I see the options Not reviewed, Reviewed Errors and Reviewed Correct. I tried to review some forms and got the message the forms have errors, tried to edit and noted some had the field of interest, testing.cov_test, as “Pending”, while others as “Negative” or “Positive”

Thinking what it means to have forms submitted with errors, yet most of the fields were selectable

Thanks for the reply.

Did you ever have a version of the form on your production server that was missing these fields?
The way that the list of fields is compiled by the export is that one “sample” report for the selected for is chosen and that report’s fields are used as headers. If the report that was picked was submitted when the form was missing certain fields, those fields won’t show up in the export.
This is a limitation of our export system.

To check whether this is the case, if you have older reports that you submitted with the older version of the form, can you either edit them or delete them and try exporting again, and check whether the field is displayed?


I see the field in the individual forms as shown below, but missing when I download

Did you ever upload a version of the form that didn’t have this field and submitted a report using this old form?

By the way, I submitted this as a bug in our GitHub tracker: Report export fields can be skipped if forms are edited over time · Issue #7437 · medic/cht-core · GitHub

@dianabarsan](dianabarsan (Diana Barsan) · GitHub), I managed to access the project in Fauxton and edited the fields by adding the two additional fields, we now can download the results

My last homework is to access the registration data, which is captured but not available in the report, and ensure my widgets display data on the analytics dashboard

@diana, tried to apply the same concept to access another form for creating contacts, and got the message “Insufficient privileges”, our partners want the data of contacts captured in the system using the contact-create form

Please make sure you’re using an admin account.

From the medic online portal, only the case-investigation form and data is available, the contact registration form and data not available. I have used the form_id, which I have realized is different from the file name and followed “Export your reports by calling: **http://<host>/api/v2/export/reports?filters[search]=&filters[forms][selected][0][code]=<form_id>**”. The form downloads yet no data is displayed

Do we have a way of having more that one form on medic mobile? Thinking on how to download the contact data

If you are creating contacts using contact forms, then you should export contacts or people. API to interact with CHT Applications | Community Health Toolkit