Issue running tutorial: "Install Valid TLS Certificate"

Hi, I am having some issue following the tutorial section of Install Valid TLS Certificate.

I ran docker compose up and I can see “medic-os” when I run the command to view list of containers i.e. docker container ls. But I am getting following message:

‘medic-os’ docker container is not running. Please start it and try again.

when I run ./scripts/

Can someone please advise? I am using Ubuntu with VirtualBox and I have also attached the screenshot below.

1 Like

Hey @niraj ! Thanks for posting your question.

I think the issue is that you’ve set up the medic-os with sudo and you’re running the script without sudo. This means that your local, non-root user can not see the the medic-os container that was created by the root user.

Ideally docker containers are run with out root or sudo for security reasons. Since the script seemed to run OK with out sudo can you try recreating your haproxy and medic-os containers with out sudo and see if the script will work?


@mrjones thank you for the response. I get error message of permission denied if I run without sudo so, instead I ran sudo ./scripts/ and results matches as shown in tutorial. However, I am getting connection timeout when I run curl -I|egrep 'SSL|HTTP|Server' instead of success as shown in tutorial screenshot. I did replace 192-168-68-40 with my IP address. I will look more into it.

@mrjones sorry, I made a silly mistake. I forgot to replace . with - in the IP address while replacing my IP address in curl -I|egrep 'SSL|HTTP|Server' Now, it does not show connection timeout error. Thanks again for the help.

@niraj - great thanks for reporting back! I’m glad we were able to resolve it.