Error following tutorial

I am following CHT tutorials and I am getting error in Contact and User Management - Part 2. When I run command to upload JSON docs to my local test instance, it fails. I ran command below (I did change username and password)

cht --url=https://<username>:<password>@localhost --accept-self-signed-certs upload-docs

The message in terminal (I am using Ubuntu) is:

0 of 3 docs uploaded OK. Full report written to: upload-docs.1-----.log.json

When I looked into json log file to debug error, for each json file I see message below:

“conflict: Document update conflict.”

Can someone please advise?

1 Like

This usually happens when the documents have been previously uploaded to the CHT instance and another attempt is made to upload without including the document revisions. If you check couchDB via fauxton using the address path_to_instance>/_utils, the documents should already be there.

Read more about how this mechanism works here.


Thanks @elijah. I created csv with new information and ran the commands again. I can now see the new information is uploaded.