Error 502 on local development instance

I got a similar problem [to this issue], the logs for nginx and API are similar to what @Esther_Moturi raised, however my couch db logs read:

What could be a possible solution?

PS. I have tried the docker kill then docker compose up command.

@kembo - welcome to the forums! Thanks for posting your question.

Can you confirm which guide and version you’re following (eg “4.x” vis the local setup or CHT docker helper or other?)?

As well, can you post the gzip file created after calling the script?

I am using 4.x local set up guide, the gzip file has a format not authorized by the upload feature. This is a sample of the cht_couchdb_1 logs though,

It is somewhat similar to the earlier photo, please have a look @mrjones or @diana

Hi @kembo

One option is to upload the gzip file to google drive and share the link here, you will get a notification to grant access when someone tries to download.

From your screenshot I can’t exactly tell what is causing your CouchDb to fail to load.

Hello @diana here’s the google drive link

Hi @mrjones I tried using the docker helper to set up the local instance, everything ran successfully. I am not sure though why the other way didn’t work (@diana, I shared my logs with you, would be glad to know underlying reasons).

1 Like

Hi @kembo

I indeed see that CouchDb is failing to start.
Could you please try to change the volume mounting point for CouchDb - so that it saves data to a different folder - and repeat the docker kill and up?