Develop Locally Issue

Hi - I am trying to install the CHT reference app on my windows computer. I was successful in running the hello-world container in Docker and was able Initialize the Project Directory, but now I cannot complete the “develop locally step”:

sudo apt update && sudo apt -y dist-upgrade
sudo apt -y install python3-pip python3-setuptools python3-wheel xsltproc

Use NVM to install NodeJS:

export nvm_version=curl -s | jq -r .name
curl -o-$nvm_version/ | $SHELL
. ~/.$(basename $SHELL)rc
nvm install 16

I get a “not found” error when I run the code lines.

I feel like this is an easy fix, but can’t think of what it is.

Any help appreciated!

Hello @gwells2-stanford!

On Windows, local CHT app development can only be done via the Windows Subsystem for Linux which provides a Linux terminal environment where you can run those commands. Are you using WSL? If so, could you try running those commands one-by-one to see which of them fails? (and then reply out here with the complete command + error message from the terminal)

Alternatively, app development can be done via a DevContainer using VSCode.

Thanks @jkuester!

I tried the VS method too. Here’s the error I receive when I place in WSL

PEDS-5KJPKN3:/tmp/docker-desktop-root/mnt/host/c/WINDOWS/system32# cd ~/cht-project
PEDS-5KJPKN3:~/cht-project# curl -s
ontainer.json > .devcontainer.json
-ash: curl: not found

-ash: curl: not found

Strange! :thinking: I thought curl was included by default in most of the WSL linux distros! Do you happen to remember which Linux you selected when setting up WSL?

Regardless, all you really need to do is download the file located at To do that you can just:

  • Open that link in a browser
  • Right click on the page and select “Save As…”
  • Save the file into your cht-project directory with the name .devcontainer.json (do not forget the leading period (.)!)

Then, I think it would be best to run the final commands from the Windows Command Prompt (and not from within WSL):

cd ~/cht-project
code --install-extension ms-vscode-remote.remote-containers
code -n .