CHT watchdog set-up

Hello @mrjones @diana

I am following these steps to set-up the cht watch dog on M1, however when i run sudo apt install -y wamerican i get

The operation couldn’t be completed. Unable to locate a Java Runtime that supports apt.
Please visit for information on installing Java.

Hi @cliff,

I don’t have a macOS machine to replicate your problem but I’m almost certain apt is a Ubuntu-specific command to install packages.
This specific step installs a dictionary of words which is later used to generate a strong and easily memorable password (see Dice-Generated Passphrases).

From what I read, macOS provides a dictionary of words out of the box so you should be able to skip this apt install step and keep going. If the password generation keeps failing, I would recommend using this website to generate a password with 7 words and use it in the outlined steps like so:

cd cht-watchdog
cp cht-instances.example.yml cht-instances.yml
cp grafana/grafana.example.ini grafana/grafana.ini
mkdir -p grafana/data && mkdir  -p prometheus/data 
cp .env.example .env
# generate a 7-words long password with
sed -i -e "s/password/$password/g" .env
echo;echo "Initial project structure created! To log into Grafana in the browser:";echo 
echo "    username: medic"
echo "    password: ${password}";echo

thanks @mokhtar , :100:

1 Like

@mokhtar @mrjones On running the containers i get

Running 0/0
 ⠋ Container cht-watchdog-prometheus-1  Creating                                                   0.1s
 ⠋ Container cht-watchdog-grafana-1     Creating                                                   0.1s
Error response from daemon: failed to mount local volume: mount ./grafana/data:/var/lib/docker/volumes/cht-watchdog_grafana-data/_data, flags: 0x1000: no such file or directory

i thought the mkdir -p grafana/data && mkdir -p prometheus/data would cover this


@cliff what version of Docker Compose (or docker-compose) are you using? In our testing we found that the v2.x version of the old docker-compose did not work with relative paths to the Docker volumes. Can you try updating your .env file to use absolute paths to your data directories?

1 Like

hello @jkuester i have edited the .env file to use absolute path

but when i run docker compose up -d still dropping the same error

hello @jkuester i deleted the volumes and works fine now



Ah, good call! Thanks for following up @cliff! Glad it is running now!