CHT Docker Helper for 4.0 not installing TLS Cert

Thanks for this [docker helper], very helpful the script!

I think there is an issue with the env file created, the common_name default doesn’t match the one given by the script (127-0-0-1 …) so I was having an issue when uploading forms because the cert wasn’t valid that was solved by adding the common_name to the .env file (thanks to @delcroip ). Maybe I missed a step but sharing the experience in case someone comes across the same issue

@magp18 - thanks for the report about the cert issues!

Can you give some more details?

The URL that the script gives back is and the CN (common name) on the cert is *

openssl s_client -showcerts -servername -connect </dev/null | grep 'my.local'|grep subject

subject=CN = *

This should work for both cht-conf and browsers alike.

You mentioned adding common_name to the .env file - is that your docker compose .env file found in ~/.medic or a different one?

Any details with steps to reproduce or error messages would be helpful - thanks!

Also - noting I moved your inquiry into technical support so others might find if they’re facing the same issue. A link at the bottom of the original post is still there for a trail too!

Sorry for the delay, I was on holidays.

I went to scripts/docker-helper-4.x and ran the script and then the common name created in the env file was not matching the output of the console. But I just ran it again and seems like it works as expected without adding this field to the env file, seems like I might have missed something when I tried before

1 Like

@magp18 - great, thanks for reporting back that the issue was solved by re-running the docker helper script for 4.x!