CHT Android debugging

Hi team ,
When the application is under internal testing ,after downloading it on the phone ,
it displays no internet connection yet the connection is working.

@Edwin can you provide some more details about your setup?

  • Does this behavior happen when using the new v1.2.0 apk? If so, what happens if you use the v1.1.0 apk?
  • Which flavor of the apk are you testing with? (e.g. the unbranded “CHT Android” app or a different project-specific one)
  • How did you install the app? (Did you sideload the apk after downloading it from GitHub or did you get it from the Play Store?)
  • Was this a fresh installation or did you have an existing version of the app install that you upgraded?
  • What version of Android are you running on the device? Also, what is the version of WebView that is installed?
  • What kind of device are you testing with? It is a real phone or an emulated device on the computer?
  • Finally, regarding the connectivity issues, can you confirm that you can connect to the CHT instance in question via the web browser in the app?
  1. on v1.1.0 github branch.

  2. I cloned it, did a git checkout.

  3. Added Build.gradle
    new_brand {
    dimension = ‘brand’
    applicationId = ‘’

Add icons, strings file with the name of the app and the URL of the CHT instance:

<?xml version="1.0" encoding="utf-8"?>

New Brand

  1. run the make command . to create both aab file and apk .

  2. signed aab file and put in in the google console. Under internal testing.

  3. got the link and downloaded it from playstore . Having the medic logo

  4. on trying to open the app i downloaded it keeps saying no internet connection.

  5. Yes i can connect to my cht instance but on the browser. Not through the app i downloaded for internal testing .

  6. Am using a real phone for testing . Android version 11

Hmm I have not seen this behavior before!

You are seeing the ConnectionErrorActivity screen. Which is getting triggered due to a page load error from the UrlHandler (the WebView wrapper).

Now is a good time to recommend double-checking the new flavor steps to make sure you did not miss anything.

The next step is going to be trying to grab logs from the phone. The error that is causing the ConnectionErrorActivity screen to be displayed should be getting logged. Can you look through the logs and reply with any errors coming from the app?

@jkuester Thankyou so much. It worked . The issue was with the url. I corrected it and it worked.

1 Like