Auto-sms received on CHT-rapidpro integration

hello community

I integrated CHT with rapidpro for the two way texting, then Started a Flow after Receiving a Message that Doesn’t Match Any Keywords but we keep on getting an auto sms received reply from CHT every time the system is texted or when a message is delivered.

cc @diana

the messages have been part of the outgoing sms

Hi @cliff, there are a couple of approaches you can consider.

If you handle responses within RapidPro, you might want to disable all auto-responses from the CHT. You can do this by disabling the transition that creates the responses to SMS. This is done by removing or disabling the default_responses transition in your settings file. For example, in the standard config you would change the default_responses transition to false.

If you want to keep some auto responses yet turn of others, you can tweak your messages in the settings file accordingly.

As a last resort, you can remove the translation text for the corresponding key in all languages, as messages with no text will not be sent.

Let us know how you fare with these techniques!

1 Like

thanks @marc for the positive feedback

hello @marc ,just wanted ti inquire if the when i add the same message translation in my settings like the one in core and remove the translation will the settings in my file overide the ones in the file of core as long as the translation_key is the same in both files ?

I would hope so.

What happens when you test it? :wink:

1 Like

:blush:thanks @marc i have just made that change and going to be soon receiving feedback form the team because it seems like setting the default_responses transition in your settings file to false kills all default responses

1 Like